Timeout on waiting for first finalized header when start light client

info from discord
any one help?

I think the problem is about your connection because after bootstrap done you couldn’t get even first finalized header, check your tcp port and be sure firewall not blocked you.

defaut port is 37000?

Could you try running it again, and ensure that your connection is stable. Not able to replicate the issue. If you still get the same error, let us know

I have replicated the issue in my server.

  1. run by docker ubuntu:22.04, with --net=host flag
  2. expose port 37000, 37001 on firewall, check successfully by nc
  3. start cmd is ./avail-light-linux-amd64 --network goldberg
1 Like

What light-client version are you running? In the latest RC, we have a better log which can help, it might not have anything to do with the connection, actually. It might be the state is dirty. Try running with --clean flag.

1.7.4 pre-compiled binary, first start node, i will try --clean flag or RC version. thanks

version 1.7.5-RC3

You are missing ca-certificates package in your distro/docker setup.

Edit: on ubuntu, it’s simply:

sudo apt install ca-certificates

done, thanks for your help